▲ Наверх
Время на сайте
Текущее время на сайте

Текущая дата на сайте
На сайте...
Всего на сайте: 19
Гостей: 16
Пользователи: 

Роботы: 
Голосование

Ваш любимый шутер от Valve?

Half-Life (все части)
CS 1.6
CS:S v.34
CS:S v2230303
CS:GO

 
 

Не запускается после обновления

fake_cross
11 февраля 2013 19:49
   Сообщение #1

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
короче, обновил я сервер до 76 версии, сервер на хосте, ОС Debian(linux)

после обновления сервер запустился (без NO_стима и папки addons)

далее я начал ставить no_steam, скачал эмулятор у вас, переменовал исходный steamclient.so в steamclient_valve.so, а на место старого закинул steamclient.so из архива(пробовал все 3), libSteam2Auth.so так же как и rev.ini и steam_appid.txt, тоже скинул куда нужно, но сервер не запускается папку addons временно убрал, чтобы было понятно что дело не в ней, вот что пишет в логах сервера:

Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Using breakpad crash handler
Setting breakpad minidump AppID = 240
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
bin/steamclient.so: undefined symbol: _ZZN22CAdapterSteamClient01214GetISteamUtilsEiPKcE9bIsLogged
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.


помогите пож))
mihaput
11 февраля 2013 20:13
   Сообщение #2

Соратник
  • 60
Награды:

Репутация: 2
Группа: Пользователи
Сообщений: 115
Регистрация: 14.11.2012

Предупреждения:
Попробуй создать в дириктории /root/.steam/ папку sdk32 и положить туда оригинальный steamclient.so или с эмулятора
fake_cross
11 февраля 2013 20:32
   Сообщение #3

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
mihaput,
в случае если копирую туда исходный steamclient.so, то пишет вот что

Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Using breakpad crash handler
Setting breakpad minidump AppID = 240
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Assert( Assertion Failed: AddInstallBaseFolder( (*g_pSteamEngine).GetUserBaseFolderInstallImage() ) == k_iDefaultInstallBaseFolder ):/home/buildbot/buildslave_steam/steam_rel_client_linux/build/src/clientdll/app
licationmanager.cpp:2356

Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130111222517_1.dmp
success = yes
response: CrashID=bp-1fde7a36-3c2d-453f-8555-195022130211


а в случае если steamclient.so, из эмулятора, то пишет следующее:

Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Using breakpad crash handler
Setting breakpad minidump AppID = 240
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
Looking up breakpad interfaces from steamclient
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
bir3yk
11 февраля 2013 20:50
   Сообщение #4

Легенда
  • 150
Награды:
 
Репутация: 194
Группа: Администраторы
Сообщений: 3996
Регистрация: 7.11.2012

Предупреждения:
fake_cross,
я думаю с текущей версией ревему у вас сервер не запуститься... ждите обновление возможно с ним будет работать, а возможно и нет.
fake_cross
11 февраля 2013 20:59
   Сообщение #5

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
bir3yk,
хорошо, а как скоро оно будет? Блин знал бы не обновлял бы пока((
fake_cross
12 февраля 2013 20:59
   Сообщение #6

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
Цитата: bir3yk
а возможно и нет.

почему? раньше же все работало как часики с вашим эмулятором)
fake_cross
19 февраля 2013 14:08
   Сообщение #7

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
после обновления http://bir3yk.net/forum/topic_180/
17.02.2013

сервер стал запускаться с эмуляторм, но падает через несколько минут после запуска,вот crash файл с ошибкой:
http://yadi.sk/d/AtR3u-dw2irp7

вирусов нету файл формата .dmp

в общем падение после обращения к файлу libtier0_srv.so
bir3yk
19 февраля 2013 14:24
   Сообщение #8

Легенда
  • 150
Награды:
 
Репутация: 194
Группа: Администраторы
Сообщений: 3996
Регистрация: 7.11.2012

Предупреждения:
fake_cross,
возможно проблема в чем то другом... проверял без SM и MM?
fake_cross
19 февраля 2013 15:32
   Сообщение #9

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
bir3yk,
врятли проблемы с MM и SM, потому что когда с ними какие-то ошибки то это пишется в логах, а так ничего нету.

в логах пишет при падении следующее:
L 02/19/2013 - 17:28:19Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20130219172900_1.dmp
success = yes
response: CrashID=bp-72620a0c-98cc-4199-b40c-7c95c2130219
./srcds_run: line 372: 9855 Segmentation fault $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Tue Feb 19 17:29:02 MSK 2013: Server restart in 10 seconds
ну и дальше перезапуск.
bir3yk
19 февраля 2013 15:42
   Сообщение #10

Легенда
  • 150
Награды:
 
Репутация: 194
Группа: Администраторы
Сообщений: 3996
Регистрация: 7.11.2012

Предупреждения:
fake_cross,
мне конечно интересно ваше мнение по поводу врятли проблемы с MM и SM, но я просил проверить работу сервера без них, а если вы считаете что виной всему эмулятор пусть будет так, такое ощущение что это у меня не работает сервер.
non_stop
19 февраля 2013 16:16
   Сообщение #11

Соратник
  • 60
Награды:

Репутация: -1
Группа: Пользователи
Сообщений: 146
Регистрация: 13.11.2012

Предупреждения:
у меня и ошибку пишет, и работает всё.
fake_cross
19 февраля 2013 23:35
   Сообщение #12

Юнец
  • 0
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 7
Регистрация: 11.02.2013

Предупреждения:
bir3yk,
хорошо, я проверил, дело действительно не в SM и MM было.

так как ругался на сошки, обновил ядро и сервер еще раз, все заработало, видимо были ошибки при обновлении.

потом добавил в bin:
libtier0.so
libvstdlib.so
из старой версии(75)
и все заработало.
bir3yk
20 февраля 2013 00:15
   Сообщение #13

Легенда
  • 150
Награды:
 
Репутация: 194
Группа: Администраторы
Сообщений: 3996
Регистрация: 7.11.2012

Предупреждения:
fake_cross,
а зачем старую версию сюда еще городить все работает и с новыми. Ну если нужны проблемы, дело то житейское.
1чел. читают эту тему (гостей: 1)
Пользователей: 0

  Сейчас: 22 августа 2017 21:39