▲ Наверх
Время на сайте
Текущее время на сайте

Текущая дата на сайте
На сайте...
Всего на сайте: 16
Гостей: 14
Пользователи: 

Роботы: 
Голосование

Ваш любимый шутер от Valve?

Half-Life (все части)
CS 1.6
CS:S v.34
CS:S v2230303
CS:GO

 
 

Не запускается сервер Left 4 Dead

alqaida
14 мая 2014 16:05
   Сообщение #1

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
После последнего обновления 1.0.2.9 при запуска сервера крашиться с ошибкой ,что не может найти точку входу в библиотеке tier0.dll.Использую эмулятр от 9.03.2014

Прикрепляю скрин:
Не запускается сервер Left 4 Dead


с нетерпением жду ответов от знатоков.
weinstreizeR
14 мая 2014 16:34
   Сообщение #2

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
alqaida,
05.03 такую же штуку выдаёт?
alqaida
14 мая 2014 16:44
   Сообщение #3

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
weinstreizeR,

сейчас попробую
bir3yk
14 мая 2014 16:47
   Сообщение #4

Легенда
  • 150
Награды:
 
Репутация: 201
Группа: Администраторы
Сообщений: 4055
Регистрация: 7.11.2012

Предупреждения:
alqaida,
просто обновите 4 оригинальны стимовских файла + steam2.dll
alqaida
14 мая 2014 17:00
   Сообщение #5

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
с 5.03.14 и с заменой библиотек на новые все так же ошибка не пропала.

ктати вот это вылазиет после нажатия на OK в ошибке точка входа:

Не запускается сервер Left 4 Dead
weinstreizeR
14 мая 2014 17:03
   Сообщение #6

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
alqaida,
Сейчас у себя попробую и отпишусь.
alqaida
14 мая 2014 18:35
   Сообщение #7

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
weinstreizeR,
как результат?
bir3yk
14 мая 2014 18:59
   Сообщение #8

Легенда
  • 150
Награды:
 
Репутация: 201
Группа: Администраторы
Сообщений: 4055
Регистрация: 7.11.2012

Предупреждения:
alqaida,
я проверял сервер на linux все работает как и раньше, попробуйте еще раз обновить сервер с валидацией файлов.
weinstreizeR
14 мая 2014 19:02
   Сообщение #9

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
alqaida,
Не запускается сервер Left 4 Dead
Как видно, загрузилось удачно и без ошибок.


Удали сначала файлы:

Сервер\bin\Steam.dll
Сервер\steamclient.dll
Сервер\tier0_s.dll
Сервер\vstdlib_s.dll

Потом закидывай RevEmu ;)

Вот тебе на всякий случай настроенный RevEmu (версия от 05.03).


А вообще, Valve в очередной раз удачно прикололись со своими либами "и там и тут".
alqaida
14 мая 2014 19:19
   Сообщение #10

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
ошибка так и не ушла,делал все по вышеописанной инструкции и настроенным эмулятором от 5.03.
Закачаю снова сервак.
как проверю отпишусь обязательно
weinstreizeR
14 мая 2014 19:47
   Сообщение #11

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
alqaida,
Он точно полностью докачен? У меня скачало полностью только с 8 попытки, всё время обрывы.
alqaida
14 мая 2014 20:11
   Сообщение #12

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
пишет fully installed в steamcmd,все-равно ошибка вылазиет эта же,а батник запуска можно если не трудно?
weinstreizeR
14 мая 2014 20:30
   Сообщение #13

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
Я для теста использовал простенький: srcds.exe -console -game left4dead -maxplayers 4 +sv_lan 0 +map "карта".

1) Серверчасть скачивал тоже с нуля.
2) Полностью провалидировал.
3) Удалил оригинальные 4 библиотеки, про которые написал выше.
4) Добавил RevEmu.
5) Запустил "простеньким" батником.

Ну, по крайней мере он при запуске не выдавал никаких ошибок...
alqaida
14 мая 2014 20:38
   Сообщение #14

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
ясно,значит недокачен останавливается на 99.42 и пишет fully installed и так уже 4-5 раз,ща буду тыкать пока не будет 100.0

...и что самое интересное в папке bin нет библиотеки steamclient.dll,во всех серверах есть а в этом нет,странно...

Цитата: weinstreizeR
Сервер\steamclient.dll
Сервер\tier0_s.dll
Сервер\vstdlib_s.dll


этих файлов нет в корне сервера,они у меня в папке bin,steamclient.dll нет вообще на сервере.

даже в СТИМе поставил сервак к игре,и не запускается выдает
Не запускается сервер Left 4 Dead
alqaida
14 мая 2014 22:37
   Сообщение #15

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
Ну и олени эти парни из Valve)))

Все решилось заменой файлов из версии 1.0.2.8 по пути СЕРВЕР\left4dead\bin

-matchmaking.dll
-matchmaking_ds.dll
-server.dll

да уж,извините парни что озадачил)))
weinstreizeR
15 мая 2014 01:10
   Сообщение #16

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
alqaida,
Меня не удивляет очередной факт кривых рук Valve. Повторюсь, серверчасть была скачана через SteamCMD с полнейшего нуля... Одна либа в bin, остальные - в корне вообще. Была мысль заменять файлы со старой версии, но я решил - не настолько всё запущено, а достаточно убрать 4 стандартных "стимовских" библиотеки. Надо было мне Вам просто скинуть все 'правильные' бинарники из новой версии. Надеюсь, сейчас после замены у Вас всё работает, и запускаете сервер без включённого Steam. :smile:
alqaida
15 мая 2014 09:49
   Сообщение #17

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
а если не трудно можно выложить папки с либами:
СЕРВЕР/bin
СЕРВЕР/left4dead/bin

что-то меня прям напрягают эти обновления.

в Steamcmd для сервера же appid будет 510,я прально понимаю?не 500?

вот мой батник
steamcmd +login логин пароль +app_update 510 validate


вот после загрузки и еще раз валидации такое окно;
Не запускается сервер Left 4 Dead

значит все должно быть гуд,даже если запускать через графический интерфейс,но нет опять она гадина
Не запускается сервер Left 4 Dead
weinstreizeR
15 мая 2014 14:01
   Сообщение #18

Знаток
  • 90
Награды:
 
Репутация: 27
Группа: Пользователи
Сообщений: 610
Регистрация: 19.02.2013

Предупреждения:
Ааа, так вот в чём дело. :lol: Нет, не 510, а 222840 - именно для скачивания в SteamCMD (тут все appid длинные, я по опыту не стал использовать 510 - заподозрил неладное). Бинарники я попозже выложу, пробуйте пока скачать сервер с данным appid ;)

Я для скачивания использовал такой батник:
steamcmd.exe +login anonymous +appid 222840 validate +quit

alqaida
15 мая 2014 14:23
   Сообщение #19

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
окей,пробую)))
alqaida
15 мая 2014 19:21
   Сообщение #20

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 23.08.2013

Предупреждения:
Скачал сервер,удалил из него:
Сервер\bin\Steam.dll
Сервер\steamclient.dll
Сервер\tier0_s.dll
Сервер\vstdlib_s.dll

Закинул выше выложенный,уже настроенный эмулятор от 5.03
и вот результат:

Не запускается сервер Left 4 Dead


хотя без эмулятора все запускается хорошо.

PS:КАЖЕТСЯ ДЕЛО В МЕТАМОДЕ ИЛИ СОУРСМОДЕ,ЩА БУДУ ПРОАВЕРЯТЬ ЕЩЕ))
1чел. читают эту тему (гостей: 1)
Пользователей: 0

  Сейчас: 16 августа 2018 12:44