▲ Наверх
Время на сайте
Текущее время на сайте

Текущая дата на сайте
На сайте...
Всего на сайте: 28
Гостей: 27
Пользователи: 
- отсутствуют
Роботы: 
Голосование

Ваш любимый шутер от Valve?

Half-Life (все части)
CS 1.6
CS:S v.34
CS:S v2230303
CS:GO

 
 

Problem with Revemu for linx.

wwahgnerbp
7 июня 2016 03:39
   Сообщение #1

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
Hi again,

I'm trying to run my csgo server with revemu for linux. I had two servers. The first server everything was working as expected. But unfortunately I had to close it. Now I have a new server. I just copied all files from the old server to the new server. It's a very clean server with few plugins. I just updated the parameter "-ip 5.9.144.83". The server should run perfectly but there is a problem. Steam players can connect but no-steam players cannot. I already tried to make a fresh install of csgo from 0. I already have tried to use the 27.04.2016 version and the 18.05.2016 Here you can see my rev.ini file
[steamclient]

PlayerName = SteamPlayer
Logging=True

# Change ClientDLL to point to the original steamclient.so
# This setting will enable VAC for your server and your server will be listed
# on Valve master server! Also, Steam clients will have their regular Steam IDs
# Please use the steamclient.dll from Steam folder!
#
# Default = (n/a)
#
ClientDLL=./bin/steamclient_server.so

# DisableUnlockedItems enables you to choose whether to use the new weapons in
# Team Fortress 2, csgo, dota2. This setting applies to you only if you are a regular player,
# or to all your clients if you are a server hoster.
#
# Default = False
#
DisableUnlockedItems = True


[GameServer]

# GameServer policy rules
# Allow revEmu v9.74 ~ 9.82 clients to join your server
#
# Default = True
#
AllowOldRev74=False

# Allow revEmu v9.63 ~ 9.73 clients to join your server
# revEmu v9.62 and below will be rejected nevertheless
#
# Default = True
#
AllowOldRev=False

# Allow unknown clients to join your server
#
# Default = True
#
AllowUnknown=False

# Allow cracked Steam clients to join your server
#
# Default = True
#
#AllowCracked=False

# Allow legitimate Steam clients to join your server
#
# Default = True
#
#AllowLegit=False

#Allowed any count connect Unknown client with one IP (25 Unknown clients 1 IP default true)
#
AllowedAnyCountConnectUnknownClientWithOneIP=False


# Allow shows bots as normal players in the server(in serverbrowser)
#
# Default = false
Fake_player= true

# Allow revemu clients to join your server (steamid subject to substitution)
#
# Default = false
RevEmu_2012 = false

# Reject text for client cs 1.6 max 128 symbol
#
RejectText = Downloading client on http://you_site.com

#Add count player in server name etc. (17/32).
#
#Default false.
#
AddCountPlayerInServerName = true

#Fix crash if you use SourceMod extension connect.ext....
#
#Default false.
#
#UseConectSM = true


[GameServerNSNet]
##Use only tf2/csgo may be dota2 ;) server example: EnableNSNetSvc = UDP
#EnableNSNetSvc = [False/UDP/TCP/BOTH]

EnableNSNetSvc = UDP

#NSNetDedicatedPort = Порт(Только для Slave серевров)
#AdditionalSlaveServer = IP:PORT
#AdditionalSlaveServer = IP:PORT
#AdditionalSlaveServer = IP:PORT
#AdditionalSlaveServer = IP:PORT
#
#
#####
#Etc.   Master Server					Slave Server1				Slave Server2
#       =============					=============				=============
#       EnableNSNetSvc = UDP 				EnableNSNetSvc = UDP 			EnableNSNetSvc = UDP 
#
#       #NSNetDedicatedPort = PORT(only Slave server)	NSNetDedicatedPort = 6570		NSNetDedicatedPort = 6571
#      	AdditionalSlaveServer = 127.0.0.1:6570		#AdditionalSlaveServer = IP:PORT	#AdditionalSlaveServer = IP:PORT
#	AdditionalSlaveServer = 127.0.0.1:6571		#AdditionalSlaveServer = IP:PORT	#AdditionalSlaveServer = IP:PORT
#	#AdditionalSlaveServer = 127.0.0.1:6572		#AdditionalSlaveServer = IP:PORT	#AdditionalSlaveServer = IP:PORT
#	#AdditionalSlaveServer = 127.0.0.1:6573		#AdditionalSlaveServer = IP:PORT	#AdditionalSlaveServer = IP:PORT
#
#


server ip: 5.9.144.83:27015

Everytime when I try to connect with no-steam client it never works. The strange part is that it works when I start the other server. Please help me because I don't know what to do anymore
bir3yk
7 июня 2016 03:43
   Сообщение #2

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
wwahgnerbp,

#NSNetDedicatedPort = 6571
wwahgnerbp
7 июня 2016 03:55
   Сообщение #3

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
added NSNetDedicatedPort = 6571 but it still not working. I'm running only 1 server in the machine. The rev-client.log returns this:
2016/06/07 02:49:04 	Destructing
2016/06/07 02:49:17 	Startup
2016/06/07 02:49:17 	Using ClientDll \"bin/steamclient_server.so\"
2016/06/07 02:49:18 	Using_Interface: SteamClient017
2016/06/07 02:49:18 	Using_Interface: SteamClient017
2016/06/07 02:49:18 	Using_Interface: SteamClient017
2016/06/07 02:49:18 	RevEmu NSNet(UDP) Service started port 22015

2016/06/07 02:49:18 	Using_Interface: SteamClient017
2016/06/07 02:49:20 	LobbyID=114382429980387627464
2016/06/07 02:53:43 	Using_Interface: SteamClient017
2016/06/07 02:54:03 	Using_Interface: SteamClient017
Looking at srcds console when I try to connect it shows nothing. It's really weird. I don't know what to do anymore. Maybe the last updated broke revemu
bir3yk
7 июня 2016 04:11
   Сообщение #4

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
wwahgnerbp,
not add #NSNetDedicatedPort = 6571

if (you not token) {
add in server.cfg sv_lan 0
add sourcemod.cfg sv_lan 1
}

:)
wwahgnerbp
7 июня 2016 04:28
   Сообщение #5

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
I use token :)
added sv_lan 0 to server.cfg and sv_lan 1 to sourcemod.cfg. still not working. Now look what we got from the rev-client.log

RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out


Dude, I'm telling you there's something wrong :v

As I said I have other server in other machine. The other server works normally.

update:


new log entries:

2016/06/07 01:46:31 	Startup
2016/06/07 01:46:31 	Using ClientDll \\"bin/steamclient_server.so\\"
2016/06/07 01:46:34 	Using_Interface: SteamClient017
2016/06/07 01:46:34 	Using_Interface: SteamClient017
2016/06/07 01:46:34 	Using_Interface: SteamClient017
2016/06/07 01:46:34 	RevEmu NSNet(UDP) Service started port 22015

2016/06/07 01:46:34 	Using_Interface: SteamClient017
2016/06/07 01:46:36 	LobbyID=112604046661239307206
2016/06/07 01:56:31 	Using_Interface: SteamClient017
2016/06/07 01:56:42 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out

2016/06/07 01:56:51 	Using_Interface: SteamClient017
2016/06/07 01:57:01 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out

2016/06/07 02:01:09 	Using_Interface: SteamClient017
2016/06/07 02:01:20 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out

2016/06/07 02:01:38 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out

2016/06/07 02:01:48 	Using_Interface: SteamClient017
2016/06/07 02:01:59 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:519492716 PreAuthentication awaiting session timed out

2016/06/07 02:17:31 	Using_Interface: SteamClient017
2016/06/07 02:17:43 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:1226595132 PreAuthentication awaiting session timed out

2016/06/07 02:29:55 	Using_Interface: SteamClient017
2016/06/07 02:30:06 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:489793499 PreAuthentication awaiting session timed out


I'll help you to help me :D

I formated the dedicated machine with Ubuntu 16.04 LTS
Downloaded CS:GO dedicated server
Renamed the original 18MB steamclient.so file to steamclient_server.so
Uploaded revemu steamclient.so
Uploaded rev.ini
edited ClientDLL=./bin/steamclient_server.so
Restarted the server two times

Tried to use EnableNSNetSvc = UDP but didn't helped so I put again #EnableNSNetSvc = UDP

I also tried to put sv_lan 0 in server.cfg but the NO-STEAM clients still cannot connect. With my steam client I can connect normally. With my no-steam game I cannot.
bir3yk
7 июня 2016 11:35
   Сообщение #6

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
wwahgnerbp,
port 22015 open?
wwahgnerbp
7 июня 2016 19:18
   Сообщение #7

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
yes it's open it's a public IP and dedicated machine. I don't use any NAT

look steam player can connect normally but no-steam players simply are ignored:

2016/06/08 01:07:32 	Startup
2016/06/08 01:07:32 	Using ClientDll \\\\\\"bin/steamclient_valve.so\\\\\\"
2016/06/08 01:07:34 	Using_Interface: SteamClient017
2016/06/08 01:07:34 	Using_Interface: SteamClient017
2016/06/08 01:07:34 	Using_Interface: SteamClient017
2016/06/08 01:07:34 	Using_Interface: SteamClient017
2016/06/08 01:07:36 	LobbyID=112604046691557681050
2016/06/08 01:08:06 	Using_Interface: SteamClient017
2016/06/08 01:08:06 	Ticket: Steam 3 Legit.
2016/06/08 01:08:06 	UserConnect IP = 196.206.14.96 | SteamID = STEAM_0:0:102183712 (234)

2016/06/08 01:08:06 	Using_Interface: SteamClient017
2016/06/08 01:10:26 	SteamDisconnect IP = 196.206.14.96 | SteamID = STEAM_0:0:102183712 

2016/06/08 01:10:27 	Destructing
2016/06/08 01:10:43 	Startup
2016/06/08 01:10:43 	Using ClientDll \\\\\\"bin/steamclient_valve.so\\\\\\"
2016/06/08 01:10:44 	Using_Interface: SteamClient017
2016/06/08 01:10:44 	Using_Interface: SteamClient017
2016/06/08 01:10:44 	Using_Interface: SteamClient017
2016/06/08 01:10:44 	Using_Interface: SteamClient017
2016/06/08 01:10:46 	LobbyID=112604046691557681050
2016/06/08 01:13:31 	Destructing
2016/06/08 01:13:44 	Startup
2016/06/08 01:13:44 	Using ClientDll \\\\\\"bin/steamclient_valve.so\\\\\\"
2016/06/08 01:13:45 	Using_Interface: SteamClient017
2016/06/08 01:13:45 	Using_Interface: SteamClient017
2016/06/08 01:13:45 	Using_Interface: SteamClient017
2016/06/08 01:13:45 	RevEmu NSNet(UDP) Service started port 22015

2016/06/08 01:13:45 	Using_Interface: SteamClient017
2016/06/08 01:13:47 	LobbyID=112604046691557681050
2016/06/08 01:39:58 	Using_Interface: SteamClient017
2016/06/08 01:40:19 	Using_Interface: SteamClient017
2016/06/08 01:46:17 	LobbyID=112604046691557681050
2016/06/08 02:16:35 	RevEmu NSNet(UDP) Service: Client's STEAM_0:0:520210681 PreAuthentication awaiting session timed out


I've tried to run the server with Ubuntu 14.04 LTS x86_x64 and Debian Debian 8.5 x86_x64 and still getting this problem. In the srcds console when a steam player joins i can see the players joining. When I try to join with my no-steam game the srcds console simply shows nothing. It's like if the no-steam client is being ignored and the rev-client.log returns the timeout error.

Here you can see the log of CSGO Client Game:

2016/06/07 22:21:26 	Using_Interface: SteamClient017
2016/06/07 22:21:26 	Using_Interface: SteamClient017
2016/06/07 22:21:27 	NSNet Client: Successfully initialized WinSock Subsystem.
2016/06/07 22:21:27 	Using_Interface: SteamClient017
2016/06/07 22:21:27 	Using_Interface: SteamClient017
2016/06/07 22:21:28 	Using_Interface: SteamClient017
2016/06/07 22:21:29 	Using_Interface: SteamClient017
2016/06/07 22:21:29 	Using_Interface: SteamClient017
2016/06/07 22:21:30 	Using_Interface: SteamClient017
2016/06/07 22:21:31 	Using_Interface: SteamClient017
2016/06/07 22:21:32 	Using_Interface: SteamClient017
2016/06/07 22:21:34 	Using_Interface: SteamClient017
2016/06/07 22:21:35 	Using_Interface: SteamClient017
2016/06/07 22:21:46 	Using_Interface: SteamClient017
2016/06/07 22:24:52 	Using_Interface: SteamClient017
2016/06/07 22:24:58 	RevEmu NSNet StatusViaUDPLobby recv: Failed to receive data from UDP Server: 10060

2016/06/07 22:25:19 	RevEmu NSNet(TCP) StatusViaTCPLobby: Could not connect to specified NSNet host.


2016/06/07 22:25:19 	Using_Interface: SteamClient017
2016/06/07 22:27:17 	Using_Interface: SteamClient017
2016/06/07 22:27:17 	time 1465349237
2016/06/07 22:27:22 	RevEmu NSNet StatusViaUDPLobby recv: Failed to receive data from UDP Server: 10060

2016/06/07 22:27:43 	RevEmu NSNet(TCP) StatusViaTCPLobby: Could not connect to specified NSNet host.


2016/06/07 22:27:44 	Using_Interface: SteamClient017


I can connect to the most of other servers but I could find some servers that I can't connect

46.174.49.54:27216
176.9.110.38:27028
216.105.171.118:27024
85.225.254.202:27039

and the client log shows the same error.

New update:

After testing everything for hours I found something interesting:

when I try to scan port UDP 22015 with NMAP the port returns "open/filtered" and I can see this in the server log

2016/06/08 11:04:26 	RevEmu NSNet(UDP) Service: Client sent too small ammount of data as a message


It means that the port is really open
wwahgnerbp
9 июня 2016 00:20
   Сообщение #8

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
Is there a solution? I'm desperate! :unhappy:
wwahgnerbp
9 июня 2016 00:21
   Сообщение #9

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 20
Регистрация: 23.07.2014

Предупреждения:
Solution found: Change the machine to intel network card. (please lock the topic)
Stanly
9 июня 2016 21:19
   Сообщение #10

Храброе сердце
  • 150
Награды:
 
Репутация: 82
Группа: Пользователи
Сообщений: 1780
Регистрация: 7.11.2012

Предупреждения:
wwahgnerbp,
strange solution =)
1чел. читают эту тему (гостей: 1)
Пользователей: 0

  Сейчас: 21 октября 2018 04:32