▲ Наверх
Время на сайте
Текущее время на сайте

Текущая дата на сайте
На сайте...
Всего на сайте: 26
Гостей: 25
Пользователи: 
- отсутствуют
Роботы: 
Голосование

Ваш любимый шутер от Valve?

Half-Life (все части)
CS 1.6
CS:S v.34
CS:S v2230303
CS:GO

 
 

RevEmu(server CSS v34 Windows)

smozzy
7 марта 2016 21:51
   Сообщение #1

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
Поставил значит я на свой сервачок(чистый) ревему патч релиз от 05.03.2016(то бишь новый патч).Вроде все норм,после установки всего что нужно было для сервачка,я его запустил поиграл,все норм,потестил.Steam_id не вроде не менялся.Ну и решил уже поставить плагины,типа випка,сд аннонсер(показывает в чат ip и Steam_ip)и заметил тогда такой момент,у меня слетала и админка и випка,начал смотреть свирять стимы с прописанными в кфг,одинаковы.Потом заметил,что Steam_id показывающий в консоли при помощи команды status,отличается от стима в сд анонсер.А так же потом заметил что обнулив кфг,и прописав випку через ркон команду.Она слетела,и тут я увидел чудо,сд аннонсер и стим сохранившийся(прописавшийся по ркон команде) в кфг(настройки випки) показывает один и тот же стим айди,а статус то врет то нет.
Стим меняется таким образом:
STEAM_0:0:123456789(стандарт)
STEAM_0:1:123456789
STEAM_1:0:123456789
STEAM_1:1:123456789
При этом в лог файлах ревему все время распознается как:STEAM_0:0:123456789
статус то показывает STEAM_0:0:123456789 то реальный.
Думал дело в клиенте,заходил с другой контры(которая не пропатченна ревему) результат тот же.
rev.ini:
Внимание! У вас нет прав для просмотра скрытого текста.


rev-client.log:

2016/03/07 13:55:28 	Startup
2016/03/07 13:55:28 	Using_Interface: SteamClient006
2016/03/07 13:55:58 	Ticket: Old Rev Emu V74.
2016/03/07 13:55:58 	UserConnect IP = 192.168.0.101 | SteamID = STEAM_0:0:404835517 (164)

2016/03/07 13:58:07 	SteamDisconnect IP = 192.168.0.101 | SteamID = STEAM_0:0:404835517 

2016/03/07 13:58:22 	Ticket: Old Rev Emu V74.
2016/03/07 13:58:22 	UserConnect IP = 192.168.0.101 | SteamID = STEAM_0:0:404835517 (164)

2016/03/07 13:58:41 	SteamDisconnect IP = 192.168.0.101 | SteamID = STEAM_0:0:404835517 

2016/03/07 14:05:46 	Ticket: Unknown.
2016/03/07 14:05:46 	UserConnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810 (0)

2016/03/07 14:06:12 	SteamDisconnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810 

2016/03/07 14:06:32 	Ticket: Unknown.
2016/03/07 14:06:32 	UserConnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810 (0)

2016/03/07 14:07:27 	SteamDisconnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810 

2016/03/07 14:17:09 	Ticket: Unknown.
2016/03/07 14:17:09 	UserConnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810 (0)

2016/03/07 14:17:48 	SteamDisconnect IP = 192.168.0.101 | SteamID = STEAM_0:1:1616117810


cd_logs.log:
[03/07/16 - 13:55:30] Лог начат
[03/07/16 - 13:56:54] Пыше[4k]а#(?не найдена. ?(локальна)[STEAM_0:0:404835517] connected
[03/07/16 - 13:58:07] Пыше[4k]а#(?не найдена. ?(локальна)[STEAM_0:0:404835517] disconnected
[03/07/16 - 13:58:22] Пыше[4k]а#(?не найдена. ?(локальна)[STEAM_1:0:404835517] connected
[03/07/16 - 13:58:41] Пыше[4k]а#(?не найдена. ?(локальна)[STEAM_1:0:404835517] disconnected
[03/07/16 - 14:05:46] Тот Самый™(?не найдена. ?(локальна)[STEAM_0:1:1084751973] connected
[03/07/16 - 14:06:12] Тот Самый™(?не найдена. ?(локальна)[STEAM_0:1:1084751973] disconnected
[03/07/16 - 14:06:32] Тот Самый™(?не найдена. ?(локальна)[STEAM_1:1:1084751973] connected
[03/07/16 - 14:07:27] Тот Самый™(?не найдена. ?(локальна)[STEAM_1:1:1084751973] disconnected
[03/07/16 - 14:17:09] Тот Самый™(?не найдена. ?(локальна)[STEAM_0:0:1084751973] connected
[03/07/16 - 14:17:48] Тот Самый™(?не найдена. ?(локальна)[STEAM_0:0:1084751973] disconnected


Такие варианты не предлагать:
AllowUnknown поставить false(пробывал выдает steam_0:0:0 игрока пускает на сервер)и мне он не выгоден.
Поставить старую версию revEmu,пробывал в феврале,проблема та же была,дел было по горло тогда,поэтому забросил сервак и не регался на форуме,не писал о проблеме,а сегодня появилось время свободное,вот и зашел на форум увидел новую версию,спросил про ее актуальность для css server'a v34 на ОС windows,проверил и проблема осталась.Прошу помочь решить мне данную проблему.Заранее спасибо
bir3yk
7 марта 2016 22:21
   Сообщение #2

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
на лог ревему можете особо не смотреть он показывает только последние цифры STEAM_0:0:1084751973 и они ни на что не влияют, по идее должен быть 0:0:1084751973, почему меняется в 34 не знаю, поставьте админку как 4 варианта 0:0:????? 0:1:?????? 1:0:??????? 1:1:????? должно помочь.
smozzy
7 марта 2016 22:28
   Сообщение #3

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
не вариант))у меня автоматическая система оплаты админки,плюс постоянно банить всех 4раза?
bir3yk
7 марта 2016 23:05
   Сообщение #4

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
ну проверю на днях
smozzy
7 марта 2016 23:12
   Сообщение #5

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
Спасибо.Буду ждать ваших результатов))
smozzy
13 марта 2016 16:58
   Сообщение #6

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
bir3yk,
ну что там?разобрались?
bir3yk
15 марта 2016 08:42
   Сообщение #7

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
проверил у себя у меня ничего не меняется, но я проверял разумеется без соурсмода... возможно он как то криво обрабатывает данные, "SteamAuthstringValidation" "no" в core.cfg SM стоит? может вы используете какую то версию SM не очень совместимую с 34 версией.
smozzy
15 марта 2016 19:51
   Сообщение #8

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
Цитата: bir3yk
SteamAuthstringValidation

в core.cfg "SteamAuthstringValidation" "no" стоит.
версия совместима с v34,также проверял другой эмулятор,esteamation и на нем такой проблемы не было,однако он мне не подходит.Ваш патч меня заинтересовал больше.
то что стоит:
sourcemod_version 1.7.1
metamod_version 1.10.4V
Попробуйте с этими версиями проверить, если дейтсвительно у вас будет меняться значит буду искать другой соурсмод,либо вы как-то посмотрите что можно будет сделать,дальше видно как говорится будет.Просто вся соль в том, что у меня пару плагинов работают только на этом см.
Reg1oxeN
16 марта 2016 01:30
   Сообщение #9

Ученик
  • 45
Награды:

Репутация: 3
Группа: Пользователи
Сообщений: 60
Регистрация: 29.07.2014

Предупреждения:
smozzy,
вам лучше поставить см версией ниже и проверить это самостоятельно.
smozzy
16 марта 2016 19:54
   Сообщение #10

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
bir3yk,
пробывал и другие версии сурсмода,история повторяется.Я заметил такой момент,я поставил плагин cd_anoncer по новой и замечаю что временами идет различие того значения что выводит анонсер и команда статус в консоли,я удалил анонсер,поставил сурсбанс,и решил и прописал себе админку.Перезаходил несколько раз на серв,на 7 раз мне сказало что у меня нет доступа к админке,хотя статус говорит что стим не изменился.При этом я зашел в панель сурсбанса и добавил стим администратора в баню и меня кинуло с сервера,но потом я смог зайти,хотя стим который показывает статус находится в бане.Я так понимаю тут три варианта:либо ревему почему-то на v34 не дружит с сурсмодом, либо он выдает запаздало стим,ну или все эти проблемы из-за того что он пытается выдать генерацию нового типа(насколько я понял STEAM3,и насколько я знаю на v34 вроде было STEAM2 аутенфикация).Если я где-то ошибаюсь поправьте.И да попробуйте проверить с сурсмодом все-таки,пропишите себе админку,и проверяйте меняется ли стим ид и при этом остается ли доступ к админке.Заранее благодарю за ваш труд.
bir3yk
16 марта 2016 20:48
   Сообщение #11

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
ревему генерит всегда один и тот же стимИД это касается и 0:0: как сервер или SM интерпретирует эти данные я не курсе, но вы похоже первый столкнулись с такой проблемой. Посмотрите какую версию вы используете и что стоит на серверах на которых нет такой проблемы.
smozzy
16 марта 2016 22:57
   Сообщение #12

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
bir3yk,
если бы я знал у кого стоит точно такой же патч ревему на v34,может кто-то тут поделиться тогда сбокрой сервера или сорсмодом чтобы не было такого недоразумения))либо может мне скинуть свою сборку?чтобы вы посмотрели в чем же там проблема,ведь раз появилась проблема у одного,значит это может случится и у другого.
smozzy
19 марта 2016 12:23
   Сообщение #13

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
bir3yk,
сервером с вашим патчем я найти не могу,но я проверял с другими сурсмодами,даже с самым стабильным и давно опробованным 1.4.2 стим меняется,однако команда status врет.Может посоветуте какую версию ревему поставить чтобы она стабильно работа на v34?
--------------------------------------------------------------------------------


Решил отключить sourcemod.После чего используя програму HLSW забанил себя по стиму,и пробывал зайти,стим не менялся,при этом на дублированном сервере с тем же эмулятором ревему только вместе с sourcemod'ом стим сменился и меня там пропустило на серв,а статус врал.без сурсмода все отлично пашет.Только вот почему-то не хочет ваш эмулятор работать с сурсмодом...Что можно сделать?пробывал разные версии sourcemod'а,история всегда повторяется.
Замечено так же что эмулятор esteamation дружит нормально с сурсмодом,однако он мне не подходит по многим причинам,можете ли вы решить проблему вашего эмулятора с сурсмодом?
bir3yk
19 марта 2016 12:54
   Сообщение #14

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
сервер на линухе версия 4100 подключился 10 раз STEAM_0:0:???????? статус показывает всегда все правильно



статус не может врать так как это серверная команда и он показывает то что есть на самом деле.
smozzy
19 марта 2016 13:02
   Сообщение #15

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
bir3yk,
и доступ к админке не пропадал?Я правильно да понял.
И да напомню у меня сервер на Windows,может имеет какое-то значение.Я просто в генерации стима не очень разбираюсь))
smozzy
19 марта 2016 13:42
   Сообщение #16

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
Странно все.Если через HLSW банить по ид,то есть ркон бан получается,то игрок баниться и зайти повторно не может,сервак не пускает.Если банить по сурсмоду,то после n перезаходов игрок спокойно допускается на сервер.
Версию 1.6.3 тоже пробывал
Метамод 1.10.4 стоит.

То есть грубо говоря соурс мод не хочет работать корректо,он получает не тот ид.Но при этом если ставить другой эмуль данной проблемы не наблюдается.
Я не знаю в чем прикол,вы попробуйте зайти на сервер,и прописать себе админку,и перезаходить и проверять доступ к команде !admin

Еще раз большое вам спасибо что пытаетесь мне помочь с этой проблемой.
Reg1oxeN
20 марта 2016 00:46
   Сообщение #17

Ученик
  • 45
Награды:

Репутация: 3
Группа: Пользователи
Сообщений: 60
Регистрация: 29.07.2014

Предупреждения:
вы случайно не оставляете патченные файлы из другого эмуля?
smozzy
20 марта 2016 04:05
   Сообщение #18

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 7.03.2016

Предупреждения:
Reg1oxeN,
нет.У меня имелось на машине три индетичных не пропатченых сервера,один пропатчил ревему,другой естеаматион.И проверял варианты разные.
bir3yk,
Проблема частично решена,копался в настройках,и наткнулся на это:
#UseConectSM = true
убрал # и сохранил.
при этом в cstrike\addons\sourcemod\extensions из папки disabled переместил файл connect.ext.1.ep1.dll и поместил в папку extensions.
Теперь у меня проблема частично решена.Частично потому что в те моменты когда у игрока стим менялся по этому принципу:
STEAM_0:0:123456789
STEAM_0:1:123456789
STEAM_1:0:123456789
STEAM_1:1:123456789
Сейчас:
STEAM_0:0:123456789
STEAM_1:0:0
Назревает вопрос,по какому принципу выдается STEAM_1:0:0 и как это предотвратить?
P.S STEAM_1:0:0 выдается любому пользователю,при этом на сервере могут даже два и более игрока одновременно находится с этим адрессом,и при этом статус пишит их реальные стим ид.Если кикнуть/забанить из сурсмод админки хотя бы одного из них,выкидывает всех.
bir3yk
20 марта 2016 05:12
   Сообщение #19

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
smozzy,
нормальный стимИД только в том случае если в логе ревему пишется что это клиент ревему, а не олдревему или ункновн или еще какую то хрень...
bir3yk
20 марта 2016 09:20
   Сообщение #20

Легенда
  • 150
Награды:
 
Репутация: 207
Группа: Администраторы
Сообщений: 4112
Регистрация: 7.11.2012

Предупреждения:
bir3yk,
connect.ext.1.ep1.dll вы уверены что это вам надо?
1чел. читают эту тему (гостей: 1)
Пользователей: 0

  Сейчас: 22 октября 2018 21:51