▲ Наверх
Время на сайте
Текущее время на сайте

Текущая дата на сайте
На сайте...
Всего на сайте: 22
Гостей: 19
Пользователи: 

Роботы: 
Голосование

Ваш любимый шутер от Valve?

Half-Life (все части)
CS 1.6
CS:S v.34
CS:S v2230303
CS:GO

 
 

CSGO Linux issue

Monster
4 июня 2015 20:02
   Сообщение #1

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
Hello,
Does anyone else have problem with server stop using emulator and start using it's own steamclient.so file (which was renamed to steamclient_valve.so)? I noticed this when one of my regular players told me he can't join, he was getting message "Failed to join..." and in his console was message "Connecting to public(server-IP). Server using '<none>' lobbies, requiring pw yes, lobby id ffffffffffffffff". It's easy to fix this, I just need to restart my server, but it is also really annoying. I'm not really sure what cause this issue or when this behavior starts, but I think it's when there are no real clients on server, only bots. If anyone experienced this issue, please tell me how did you solve it (at the moment I'm thinking about installing plugin for auto-restart when my server is empty).

SourceMod 1.7.2-dev+5200, by AlliedModders LLC
Metamod:Source version 1.10.5-dev

Thanks,
Monster.
Stanly
5 июня 2015 12:03
   Сообщение #2

Храброе сердце
  • 150
Награды:
 
Репутация: 82
Группа: Пользователи
Сообщений: 1780
Регистрация: 7.11.2012

Предупреждения:
Monster,
Hello.
First of all you should update SourceMod to v. 1.7.3 (stable branch) and MetaMod to v. 1.10.6 (stable branch)
Could you write your server addr?
Do you have sv_lan 1 in your sourcemod.cfg? If yes, you should remove this line and restart your server. Because now a lot of gamers play with original engine.dll in their clients and it means if you have sv_lan 1 in your sourcemod.cfg then they not be able to connect to your server. Furthermore you need to have this line - "EnableNSNetSvc = UDP" in your rev.ini file (without quotes and this comment sign - #). And of course port 6569 must be opened in your server, otherwise lobby won't be created.
DabuDos
5 июня 2015 13:50
   Сообщение #3

Соратник
  • 60
Награды:

Репутация: 7
Группа: Пользователи
Сообщений: 211
Регистрация: 26.11.2014

Предупреждения:
Monster,
Try to use the steamclient_nologging.so
It fixed some errors for me. Maybe it helps :)
Monster
6 июня 2015 03:25
   Сообщение #4

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
Stanly, I have two servers, both was having same problem
195.154.250.215:27016
195.154.250.215:27019
It seems that "sv_lan 1" in sourcemod.cfg was the problem. Before the latest update sv_lan 1 was needed so I forgot about it. I will monitor my server just in case it apears again and I will inform you guys if that fixed the issue pernamently.

DaduDos,
Thanks, if this fails I'll try that.

Thank you for your reply.
Stanly
6 июня 2015 10:02
   Сообщение #5

Храброе сердце
  • 150
Награды:
 
Репутация: 82
Группа: Пользователи
Сообщений: 1780
Регистрация: 7.11.2012

Предупреждения:
Monster,
Okay, look. I have tried connect to both of your servers and I was successfully connected on one of them (195.154.250.215:27016), but I can't connect to your second server - 195.154.250.215:27019. It happen because this server 195.154.250.215:27016 was run earlier than 195.154.250.215:27019
And now this server - 195.154.250.215:27016 is master and this - 195.154.250.215:27019 is a slave server. It means that your servers are not linked with each other in rev.ini

What you need to do:
1. These lines must be in your first server (195.154.250.215:27016):
EnableNSNetSvc = UDP
AdditionalSlaveServer = 127.0.0.1:6570
2. These lines must be in your second server (195.154.250.215:27019):
EnableNSNetSvc = UDP
NSNetDedicatedPort = 6570
3. Your first server - 195.154.250.215:27016 should be run earlier than your second.

But in the next RevEmu update owners few CS:GO (Tf2, Dota2) servers on one machine won't need to link their servers with each other.
ctmone
6 июня 2015 17:25
   Сообщение #6

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 28
Регистрация: 5.04.2015

Предупреждения:
I have same problem, so in tutorial you say
Open folder [ServerRoot]/csgo/cfg/sourcemod/sourcemod.cfg using notepad and add sv_lan \\"1\\" in the end of file. And save file.


So remove sv_lan 1 from sourcemod.cfg or not?

My rev.ini





Server: 93.119.24.80:27015
Monster
6 июня 2015 18:59
   Сообщение #7

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
Thanks Stanly, I didn't know it was necessary to link them like that. As owner of small hosting (mainly used for our community members) I'm glad to hear you will change that in next update. For now there is no problems but I'll see if they show up in future. I figured out that the problem appeared once all no-steam clients exit the server and map changes. Linking the servers seems to fix this. I'll post here if it happens again within next 48h.

ctmone, don't put sv_lan 1 in your sourcemod.cfg since it is not needed anymore. As Stanly kindly explaind here, most clients use original engine.dll file, so if you put "sv_lan 1" in your sourcemod.cfg it conflicts with their game client and they can't join. If you have multiple servers on your machine do as Stanly explained here.
ctmone
6 июня 2015 19:58
   Сообщение #8

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 28
Регистрация: 5.04.2015

Предупреждения:
Monster,
My server is hosted is not in my pc.
Stanly
7 июня 2015 03:17
   Сообщение #9

Храброе сердце
  • 150
Награды:
 
Репутация: 82
Группа: Пользователи
Сообщений: 1780
Регистрация: 7.11.2012

Предупреждения:
Monster,
You are welcome. Yes, now I can connect to both of your servers. Moreover they really well configured and fast-moving mode makes them unforgettable. So I offer you our test promotion (it's free) for both of these servers. All you need to do it's agree with my suggestion and I will switch on our promotion for 1 circle in both of them. Sounds nice, isn't it? )

ctmone,
i will rewrite tutorial after sleep, because now i'm really tired =(
But on your server is installed only one server now (it's your's) - link for you
You have to delete sv_lan 1 from sourcemod.cfg, write "EnableNSNetSvc = UDP" (without quotes) in your rev.ini file on server but both of these points you have done. How I see in your rev.ini file, you uncommented this line - NSNetDedicatedPort = 6569, but it's use only for slave server. You should comment this line, like this - #NSNetDedicatedPort = 6569 (with this symbol - #).
Moreover port 6569 has been opened already and it's perfect =) You need only uncomment one line.
Monster
7 июня 2015 14:57
   Сообщение #10

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
Stanly,
Sure, I'm always open for suggestions, just send me message about it.
ctmone
7 июня 2015 15:20
   Сообщение #11

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 28
Регистрация: 5.04.2015

Предупреждения:
Stanly,
Without sv_lan 1 in sourcemod.cfg dont work to connect.

Retrying public(93.119.24.80:27015) ...
Server using 'public' lobbies, requiring pw no, lobby id ffffffffffffffff
Server only accepting connections from game lobby 91.38.127.194:27005 97071523.
#Valve_Reject_Connect_From_Lobby


After i put sv_lan going to connect .
Monster
7 июня 2015 16:48
   Сообщение #12

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
ctmone,
Are you sure you are using latest RevEmu? Because in latest release of RevEmu you don't need to have sv_lan 1 in sourcemod.cfg.

Download latest RevEmu, rename original steamclient.so in your [RootDir]/bin to steamclient_valve.so, and copy steamclient.so from your [RevEmu] folder to your [RootDir]/bin folder. In your batch file (it is used for starting server, if you can't change it manualy ask your hosting provider) add +sv_pure 0 +sv_lan 0 at the end of startup line. Also in your [RootDir]/csgo/cfg/server.cfg (if you don't have this file create it) add host_info_show 2, host_players_show 2, sv_lan 0. After you have done that, restart your server and try to connect via no-steam client.

Also if you want no-steam skins to show for clients copy files from [RevEmu]/csgo/platform to [RootDir]/platform, then in rev.ini uncomment EnableNSNetSvc = UDP. If the port 6569 on machine is opened they will see skins they are set to use. That should be it (be sure to restart server after changes).
ctmone
7 июня 2015 18:29
   Сообщение #13

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 28
Регистрация: 5.04.2015

Предупреждения:
2015/06/07 17:24:10 Check availability connect server with Lobby LobbyID=

2015/06/07 17:25:34 RevEmu NSNet StatusViaUDPLobby recv: Failed to receive data from UDP Server: 10060

2015/06/07 17:25:56 RevEmu NSNet(TCP) StatusViaTCPLobby: Could not connect to specified NSNet host.
Monster
7 июня 2015 18:55
   Сообщение #14

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
NSNetDedicatedPort = 6569
Did you commented this line in your rev.ini (put # symbol, like this #NSNetDedicatedPort = 6569)? After that restart your server. Since there is only one csgo server on that machine, there is no need for you to ever uncomment that line, you only need to uncomment EnableNSNetSvc = UDP (Stanly told you that in his previous post). Also check the post I wrote for you, make sure you do everything like it is written, if you skip just one step it will probably fail to work properly.
MAMAC
7 июня 2015 19:00
   Сообщение #15

Соратник
  • 60
Награды:

Репутация: 2
Группа: Пользователи
Сообщений: 109
Регистрация: 11.09.2014

Предупреждения:
im try to help him and we try everything commented uncomented with and whitout nsnet TCP and UDP master and slave sv_lan 0 and sv_lan .... everything.... im assume that his hosting have some other servers on same machine or 6569 is firewalled



RevEmu NSNet StatusViaUDPLobby recv: Failed to receive data from UDP Server: 10060

2015/06/07 17:51:52 RevEmu NSNet(TCP) StatusViaTCPLobby: Could not connect to specified NSNet host.



every time when i try to connect i get 10060 error.... and his hosting restrict him from root folder that is a problem, we cant check rev log from server....



EDIT: no steam work ok, cTmoNe CS:GO Server (0/16), as u see he have player number in name, only skins are problem and that is why player cant connect
Monster
7 июня 2015 19:14
   Сообщение #16

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
MAMAC & ctmone,
If he can read the rev.ini file he must have access to server root directory, either via FTP client or via WebFTP, otherwise he wouldn't be able to access it. As far as I know, port 6569 is used for transfering skins to/from other clients. He can try to comment the EnableNSNetSvc it should block transfering skins, but I highly doubt that is causing issues with his server (if that port is blocked by firewall it would only show default skins, at least that is what happens on my machine when I tested it). Did you guys added sv_pure 0 and sv_lan 0 to your start line or only server.cfg? I'm sure if those posts here don't help you, someone who had similar issue will post his solution for you. If you wish, you can contact me so we can try to fix it.

@offtopic
Mamac, engleski ti je savrsen :lol:
MAMAC
7 июня 2015 19:20
   Сообщение #17

Соратник
  • 60
Награды:

Репутация: 2
Группа: Пользователи
Сообщений: 109
Регистрация: 11.09.2014

Предупреждения:
hah trudim se :) do hosta je a host je linkovao rev.ini u poseban folder i bin folder takodje tako da sumnjam da mu je hosting nesto caprkao tu, jer kada owerwritujes steamclient.so server mora da padne kod njega se to ne desava, ili nije pravi folder hosting linkovao nama ili je sam steamclient.so linkovan, sto mi daje jedino ideju da vise servera koristi no steam i zato ga je hosting linkovao da ne mora rucno svima da salje novi rev.... vjerovatno je zato i blokao root folder servera.....
Monster
7 июня 2015 19:34
   Сообщение #18

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 15
Регистрация: 11.01.2015

Предупреждения:
U tom slucaju mora da se obrati hostingu, ako nema pristup ovim fajlovima on nista ne moze napraviti sa svoje strane. Vecina stranih hostinga ne dozvoljava krekovanje servera, moguce da je zbog toga. Sto se tice padanja servera kada uradis overwrite, na csgo se to nece desiti osim ako je promjena mape buduci da csgo malo drugacije radi (znam ovo jer sam testirao prije). Ako mu je IP servera onaj koji je gore dao, kada provjeris na steam api, tamo je dignut samo 1 csgo server, ali taj server kada dodam na steam mogu uci na njega dok preko no-steam ne mogu sto mi automatski daje da nije pravilno podesio nesto. Ne znam vise sta bih vam rekao ako mu host stvarno ne dozvoljava root pristup :/ Ja imam na svojoj masini 2 no-steam servera koja sam podesio kako sam gore napisao i rade savrseno.
Stanly
8 июня 2015 00:38
   Сообщение #19

Храброе сердце
  • 150
Награды:
 
Репутация: 82
Группа: Пользователи
Сообщений: 1780
Регистрация: 7.11.2012

Предупреждения:
Monster,
Okay, I added your servers to our promotion on 1 circle half an hour ago. 1 circle will last 2 days, so you have time to test our promotion.

MAMAC,
you're right, it seems that port 6569 is closed or firewalled and not to accept any packages. So ctmone you should write to your hosting and ask to open port 6569 like UDP in order to your server will be able to create lobby for no-steam players.
ctmone
8 июня 2015 01:41
   Сообщение #20

Новобранец
  • 15
Награды:

Репутация: 0
Группа: Пользователи
Сообщений: 28
Регистрация: 5.04.2015

Предупреждения:
Stanly,
Ok thx for support.
1чел. читают эту тему (гостей: 1)
Пользователей: 0

  Сейчас: 21 сентября 2018 12:44